Plantronics Manager Pro - Custom MSI installer access impaired
Incident Report for Plantronics
Resolved
This incident has been resolved.
Posted May 24, 2022 - 21:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2021 - 06:27 UTC
Investigating
There appears to be an Amazon AWS operations issue which is impairing our ability to create custom MSI installers for all tenants. We are investigating further and attempting to mitigate the issue until AWS is able to implement a final resolution.
Posted Dec 08, 2021 - 00:32 UTC
This incident affected: North America (Plantronics Hub MSI Creation), Europe (Plantronics Hub MSI creation), and Australia (Plantronics Hub MSI creation).